WordPress : Jetpack の更新で久しぶりに白画面出現😭

お客様のご依頼によりサイト修正を行うべく、ダッシュボードを開こうとしたら、久しぶりの白画面に遭遇しました😓
ダッシュボードすら開けなくなる例のアレです💦

Parse error: syntax error, unexpected ‘[‘, expecting ‘)’ in /home/……………/wp-content/plugins/jetpack/……………… on line 220

少々ググって見ると、何人か同じ目にあっている人を発見しました。
まあやはりここ数日のことですね。
先週の月曜(7/2)はまだ問題なしでしたが、更新日付を見ると、jetpackは「2018/07/04 12:39:00」になってました。
おそらく6.3でしょうか。
弱小プラグインならまだしも、Jetpack にやらかされるとは思いもしませんでした。不覚。。。

とりあえず、Jetpackのプラグインフォルダをリネームして復活させました。

月曜日以降は触ってなかったので、更新した記憶があるような、ないような。。。
仮に更新していたとしても更新直後は問題なかったはずなのがまた痛いですね。
次回から更新後に再ログインして確認するよう手順を見直そうかと思います。

Jetpack上では、WordPress の必須バージョン: 4.7以上 とありますが、勿論いまは「4.9.7–ja」なので無問題です。
いまの最新は6.3.2で、リリース日は7/4、ううむ。。。
PHPのバージョンが悪いという書き込みも見たのですが、Hetemlのレンタルサーバなので、勝手に動かせません。
PHP7.1がいいとかなんとか。

確認したところ、旧サーバのバージョンは、5.4。。。
いまの旧サーバのままでも、7.1には出来るっぽい感じはします。
が、どうせ9月末にはシマンテック(デジサート)のセキュリティシール契約期限が切れるので、そのタイミングでSSL化して新サーバへ移転させる予定でした。うーむむむん。。。という感じです。

余談ですが、同じ件で困っていた方、まあまあ素人さんと見受けられ、見当違いの場所(WordPress.com)に書き込んでました。
まだ困っているかもと思い、質問していた人のサイトへ行ってみたら、どうやら内容がパクリ系バイラルっぽかったので、スルーでいいやと😓

コメントを残す